WordPress ソースコードを整形する SyntaxHighlighter

SyntaxHighlighter Evolved を入れてみました。WordPress バージョン3.xx(調べるのメンドイ)ですが、ん~~すんなり動きませんでした。

デフォルトでは、コードを表示するにはしてくれるのですが、ソースをコピーなどのボタンが表示されない状態でした。

テンプレートの関係などあるのかなと思い、複数のテンプレートでも試しましたが、変化なしでした。

いろいろ調べました&同じようなプラグインを複数試しましたが、同じような感じだったのですが、プラグインの設定の「SyntaxHighlighterのバージョン」っていうのを最新じゃなくて、「Version 2x」みたいな古いやつにすると期待通りに動きました。

同じようにお困りの方がいれば、「Version 2x」で一度お試しください。

<?php echo "こんな感じで表示されます。" ; ?>
<?php echo "こんな感じで表示されます。" ; ?>
<?php echo "こんな感じで表示されます。" ; ?>
投稿日:
カテゴリー: WordPress

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です